Emails to @yahoo.com are frequently failing to deliver
Incident Report for SmugMug
Resolved
Deliverability to @yahoo.com email addresses has improved. We're still watching the situation closely as Yahoo's systems are not 100%.
Posted Mar 17, 2015 - 10:55 PDT
Identified
Many emails to @yahoo.com have been failing to deliver. We’re working with our email provider and Yahoo on getting our emails to be properly delivered.
Posted Mar 16, 2015 - 17:41 PDT