Read-only: Unexpected maintenance
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 26, 2016 - 16:55 PDT
Investigating
We’re moving SmugMug into temporary read-only mode so we can safely troubleshoot an issue. Sorry for the hassle! We’ll be back ASAP.
Posted 10 months ago. Sep 26, 2016 - 14:41 PDT
This incident affected: Web.