Support E-Mail Responses Delayed
Incident Report for SmugMug
Resolved
Support messages are flowing in now and we're handling the backlog of requests.
Posted Jan 28, 2016 - 17:50 PST
Investigating
Responses to help/support/heroes are currently delayed due to problems with our support portal provider Desk.com. Existing replies will be handled, queued, and sent when our provider is back up.
Posted Jan 28, 2016 - 08:10 PST
This incident affected: Support & Help Pages.