Errors Publishing to Facebook
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 03, 2017 - 15:53 PDT
Investigating
We’re experiencing issues publishing content to Facebook. We're on the case.
Posted 20 days ago. Oct 03, 2017 - 13:00 PDT