Customer support responses delayed
Incident Report for SmugMug
Resolved
Support emails are being sent normally again. Previously queued emails will catch up over the next hour or so.
Posted Nov 04, 2014 - 11:36 PST
Identified
Email responses to help/support are currently delayed. Existing replies will be queued and sent when our provider is back up.
Posted Nov 04, 2014 - 08:51 PST
This incident affected: Support & Help Pages.