Delayed support e-mail
Incident Report for SmugMug
Resolved
Support e-mail responses are working normally.
Posted Aug 30, 2015 - 21:11 PDT
Identified
Responses to help/support/heroes are currently delayed. Existing replies will be handled, queued, and sent when our provider is back up.
Posted Aug 30, 2015 - 19:13 PDT
This incident affected: Support & Help Pages.