Site unavailable
Incident Report for SmugMug
Resolved
We have deployed a fix for our web servers and the site has returned to normal as of 11:54am PST.
Posted Oct 22, 2013 - 11:54 PDT
Identified
We have identified an issue with our web servers and are currently fixing the problem.
Posted Oct 22, 2013 - 11:51 PDT
Investigating
We’re sorry! SmugMug is temporarily unavailable, and our ops team is working on a fix. We’ll be back ASAP.
Posted Oct 22, 2013 - 11:47 PDT