Uploads processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Jul 31, 2015 - 00:40 PDT
Investigating
Uploads are processing slowly due to a variety of system slowness from AWS. We'll post another update when processing times return to normal.
Posted Jul 30, 2015 - 23:55 PDT
This incident affected: Uploads.