Uploads Queuing
Incident Report for SmugMug
Resolved
Upload processing speeds have returned to normal.
Posted Aug 10, 2015 - 04:27 PDT
Investigating
Image uploads are currently being held in a queue for later processing.
Posted Aug 10, 2015 - 02:38 PDT