Uploads processing slowly, image loading intermittently slow

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Sep 17, 2020 - 02:13 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2020 - 21:47 PDT

Investigating

Uploads are processing slowly, and some images are loading slowly. Our team is working on a fix.
Posted Sep 16, 2020 - 21:22 PDT
This incident affected: Photos/Videos and Uploads.