Help pages unavailable

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Apr 16, 2021 - 09:11 PDT

Investigating

Our help documentation provider is working on this problem. Please contact help@smugmug.com to reach our support heroes.
Posted Apr 16, 2021 - 09:03 PDT
This incident affected: Support & Help Pages.