Site unavailable
Incident Report for SmugMug
Resolved
We have identified the cause of the incident and changes have been put in place to restore normal service.
Posted Dec 01, 2021 - 16:02 PST
Investigating
We’re sorry! SmugMug is temporarily unavailable, and our ops team is working on a fix. We’ll be back ASAP.
Posted Dec 01, 2021 - 15:52 PST
This incident affected: Web, Photos/Videos, and Search.