Uploads processing slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 08:24 PST

Investigating

Uploads are processing slowly. Our team is working on a fix.
Posted Jan 27, 2026 - 07:20 PST
This incident affected: Photos/Videos and Uploads.