Pages loading slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 20:51 PDT

Update

We are continuing to investigate this issue.
Posted Apr 10, 2026 - 20:51 PDT

Update

We are continuing to investigate this issue.
Posted Apr 10, 2026 - 20:48 PDT

Investigating

Pages are loading more slowly than usual. Our engineers are on the case.
Posted Apr 10, 2026 - 20:21 PDT
This incident affected: Web, Photos/Videos, and Search.