Photo Upload Delays
Incident Report for SmugMug
Resolved
The performance problems with uploads has been resolved and the backlog of queued requests has cleared. Upload processing is back to normal.
Posted Jun 11, 2015 - 07:52 PDT
Investigating
We're investigating reports of longer than normal process times for newly uploaded images.
Posted Jun 11, 2015 - 06:01 PDT