Stats are processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Apr 15, 2022 - 02:44 PDT
Monitoring
Stats are processing slowly while we perform some maintenance and upgrades on the stats system. We expect these delays to be resolved in 24-48 hours.
Posted Apr 13, 2022 - 14:26 PDT