Slow Search Results
Incident Report for SmugMug
Resolved
We're continuing to monitor and improve search performance
Posted Apr 17, 2018 - 16:30 PDT
Investigating
We are aware of slow search results and are working on a resolution
Posted Apr 17, 2018 - 07:53 PDT
This incident affected: Web and Search.