Uploads processing slowly, images loading intermittently

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Nov 06, 2023 - 07:47 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2023 - 07:15 PST

Identified

Uploads are processing slowly and images are loading intermittently. Our team is working on a fix.
Posted Nov 06, 2023 - 05:59 PST
This incident affected: Photos/Videos and Uploads.