Help pages unavailable
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Aug 10, 2018 - 16:18 PDT
Identified
Our support and help pages are currently unavailable. We're working with our knowledge base provider to get this fixed. In the meantime, any questions should be sent to help@smugmug.com. Thank you for your patience.
Posted Aug 10, 2018 - 15:56 PDT
This incident affected: Support & Help Pages.