Site unavailable - AWS cloud outage

Incident Report for SmugMug

Resolved

This incident has been resolved.
Marketing pages may load inconsistently as they have a dependency that has been intermittently down.
Posted Oct 20, 2025 - 09:39 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 02:31 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 01:23 PDT

Investigating

We’re sorry! SmugMug is temporarily unavailable due to a major issue affecting Amazon Web Services, and we are working with them on a fix.
Posted Oct 20, 2025 - 00:17 PDT
This incident affected: Web, Photos/Videos, Search, and Uploads.