Videos processing slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Jun 23, 2022 - 02:27 PDT

Investigating

Video uploads are processing slowly. We’re on the case.
Posted Jun 22, 2022 - 22:41 PDT
This incident affected: Uploads.