Videos processing slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Nov 10, 2020 - 16:40 PST

Investigating

Video uploads are processing slowly. We’re on the case.
Posted Nov 06, 2020 - 09:10 PST