Images loading slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Jun 06, 2022 - 13:09 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 06, 2022 - 12:20 PDT

Update

We are continuing to investigate this issue.
Posted Jun 06, 2022 - 12:14 PDT

Investigating

Images are loading more slowly than usual. Our engineers are on the case.
Posted Jun 06, 2022 - 12:14 PDT
This incident affected: Photos/Videos.