Videos processing slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted 4 years ago. Sep 27, 2021 - 23:56 PDT

Identified

Video uploads are processing slowly. We’re on the case.
Posted 4 years ago. Sep 27, 2021 - 14:54 PDT
This incident affected: Uploads.