Search pages loading slowly

Incident Report for SmugMug

Resolved

This incident has been resolved.
Posted Feb 28, 2021 - 01:29 PST

Investigating

Search pages are loading more slowly than usual. Our engineers are on the case.
Posted Feb 27, 2021 - 19:59 PST
This incident affected: Search.