Image organizer tool degraded.
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Mar 12, 2016 - 19:20 PST
Investigating
Some users have reported problems using the image organizer. Our engineers are aware of the problem and are working to resolve this as soon as possible.
Posted Mar 12, 2016 - 18:13 PST
This incident affected: Web, Photos/Videos, and Support & Help Pages.