Uploads processing slowly
Incident Report for SmugMug
Resolved
Upload processing has returned to normal. Sorry for the interruption.
Posted 10 months ago. Jan 27, 2017 - 09:20 PST
Investigating
Uploads are processing slowly. Our team is working on a fix.
Posted 10 months ago. Jan 27, 2017 - 07:17 PST
This incident affected: Uploads.