Read-only: Unexpected maintenance
Incident Report for SmugMug
Resolved
We have resolved the underlying error and everything is back to normal.
Posted 10 months ago. Sep 12, 2016 - 21:08 PDT
Investigating
We’re moving SmugMug into temporary read-only mode so we can safely troubleshoot an issue. Sorry for the hassle! We’ll be back ASAP.
Posted 10 months ago. Sep 12, 2016 - 20:46 PDT
This incident affected: Web, Photos/Videos, and Uploads.