Slow response to help requests
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Aug 11, 2015 - 18:15 PDT
Identified
Support replies may be delayed several hours due to ongoing service issues with Desk.com.
Posted Aug 11, 2015 - 10:40 PDT
This incident affected: Support & Help Pages.