Stats are undercounted since 4/14
Incident Report for SmugMug
Resolved
Stats for 4/14-4/24 are now up to date.
Posted about 1 month ago. Apr 25, 2017 - 10:03 PDT
Identified
We've identified the bug causing this problem and are now reprocessing stats.
Posted about 1 month ago. Apr 21, 2017 - 13:58 PDT
Investigating
Stats are undercounted from 4/14 on. Our engineers have been investigating this issue.
Posted about 1 month ago. Apr 21, 2017 - 10:07 PDT