Blip in how some pages are loading
Incident Report for SmugMug
Postmortem

We've identified and repaired the root cause of this problem.

Posted Dec 05, 2017 - 17:56 PST

Resolved
We resolved this issue around 19:10 Pacific, and we are working to prevent this bug in the future.
Posted Dec 04, 2017 - 19:10 PST
Investigating
A number of people may experience momentary issues with how some website pages are displaying. We're getting to the bottom of this bug and will update with more info once we've made a fix.
Posted Dec 04, 2017 - 18:47 PST
This incident affected: Web, Photos/Videos, and Search.