Upload problems
Incident Report for SmugMug
Resolved
The problems with uploading have been resolved and a permanent fix is in place.
Posted Jun 08, 2015 - 22:24 PDT
Identified
We have identified an issue with uploading and are working on a permanent fix.
Posted Jun 08, 2015 - 21:23 PDT
Investigating
We’re seeing some issues with photo and video uploads. We’ll take a closer look and will update you when we have a fix.
Posted Jun 08, 2015 - 20:56 PDT
This incident affected: Uploads.