Replacing photos using Chrome or Safari
Incident Report for SmugMug
Resolved
We've fixed the problem. Thank you for your patience.
Posted Nov 27, 2013 - 03:25 PST
Investigating
We are having problems replacing images using Chrome or Safari. A workaround while we fix this is to use another browser.
Posted Nov 27, 2013 - 02:22 PST
This incident affected: Uploads.