Smart galleries and populars are processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Aug 29, 2015 - 05:20 PDT
Identified
Certain smart galleries and populars are updating slowly. Our engineers have been working on this issue.
Posted Aug 27, 2015 - 17:52 PDT