Site unavailable
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 28, 2017 - 16:01 PST
Update
Web performance and photo delivery times have returned to normal. Upload processing is backlogged while we launch more capacity to handle it.
Posted 5 months ago. Feb 28, 2017 - 15:00 PST
Update
Amazon S3 has functionally recovered, though photo loading and uploads are performing significantly slower than normal. We'll keep you updated on this.
Posted 5 months ago. Feb 28, 2017 - 14:27 PST
Update
Read operations such as viewing photos are now working. Uploading is not consistently functional yet; we have an ETA of an hour for full functionality.
Posted 5 months ago. Feb 28, 2017 - 13:18 PST
Identified
Amazon S3 storage service is currently operating with severely degraded performance. We're working with them to get the problem repaired as soon as possible. Until it is repaired, SmugMug sites will run slowly or not load.
Posted 5 months ago. Feb 28, 2017 - 10:05 PST
Investigating
We’re sorry! SmugMug is temporarily unavailable, and our ops team is working on a fix. We’ll be back ASAP.
Posted 5 months ago. Feb 28, 2017 - 09:48 PST
This incident affected: Web, Photos/Videos, Search, and Uploads.