Pages/Images loading slowly in Northeastern US
Incident Report for SmugMug
Resolved
This problem was fully repaired at 13:40 Pacific.
Posted Feb 26, 2015 - 13:56 PST
Monitoring
Pages and images have been loading more slowly than usual in the Northeastern US due to local CDN congestion, starting at 12:50 (Pacific time). We're on the case.
Posted Feb 26, 2015 - 13:18 PST