Broken photos
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Aug 10, 2015 - 03:40 PDT
Update
Continuing to work on resolving performance problems from Amazon S3. In the interim pages will load slowly and some images may not display.
Posted Aug 10, 2015 - 02:20 PDT
Investigating
We are investigating an issue where we are not serving photos. More as we find it.
Posted Aug 10, 2015 - 00:27 PDT
This incident affected: Web and Photos/Videos.