Images loading slowly
Incident Report for SmugMug
Resolved
This problem has been repaired; thank you for your patience.
Posted Dec 01, 2014 - 21:11 PST
Identified
Images are loading more slowly than usual. Our engineers have identified the problem and are fixing it now.
Posted Dec 01, 2014 - 20:29 PST
This incident affected: Web and Photos/Videos.