Read-only: Unexpected maintenance
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 26, 2016 - 18:04 PDT
Investigating
We’re again moving SmugMug into temporary read-only mode so we can safely troubleshoot an issue. Sorry for the hassle! We’ll be back as soon as we get this fixed.
Posted 10 months ago. Sep 26, 2016 - 17:05 PDT
This incident affected: Web, Photos/Videos, Search, Support & Help Pages, and Uploads.