Blip in how some pages are loading
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted May 01, 2014 - 15:41 PDT
Investigating
A small number of people may experience momentary issues with how some website pages are displaying. We're getting to the bottom of this bug and will update with more info once we've made a fix.
Posted May 01, 2014 - 15:33 PDT
This incident affected: Web, Photos/Videos, Search, Support & Help Pages, and Uploads.