Video loading errors on some devices
Incident Report for SmugMug
Resolved
We have fixed this error. Thank you for your patience.
Posted Oct 23, 2013 - 18:02 PDT
Identified
Video loading is currently failing on most desktop web browsers. Our engineers are on the case.
Posted Oct 23, 2013 - 17:51 PDT