Upload problems
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 5 months ago. Nov 29, 2016 - 10:21 PST
Investigating
We’re seeing some issues with photo and video uploads. We’ll take a closer look and will update you when we have a fix.
Posted 5 months ago. Nov 29, 2016 - 08:30 PST
This incident affected: Uploads.