Upload problems
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 27, 2016 - 13:41 PST
Investigating
We’re seeing some issues with photo and video uploads. We’ll take a closer look and will update you when we have a fix.
Posted 8 months ago. Nov 27, 2016 - 12:55 PST
This incident affected: Uploads.