Outside Network Issue
Incident Report for SmugMug
Resolved
We experienced an Internet connectivity issue with a provider outside of our network. The issue has been resolved and the service is operating normally.
Posted Jun 30, 2015 - 19:33 PDT
Identified
We are currently monitoring an external Internet provider issue that is causing interrupted service connectivity for some users.
Posted Jun 30, 2015 - 18:38 PDT
This incident affected: Web and Photos/Videos.