Uploads processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 9 months ago. Aug 22, 2016 - 13:22 PDT
Identified
Uploads are processing slowly. We're expanding our capacity to handle a large influx of new uploads, and should be caught up shortly.
Posted 9 months ago. Aug 22, 2016 - 12:54 PDT
This incident affected: Web and Uploads.