Delayed support e-mail
Incident Report for SmugMug
Resolved
Desk.com is performing normally now and we're once again able to respond to you quickly.
Posted Jan 26, 2016 - 11:27 PST
Investigating
Responses to help/support/heroes are currently delayed due to problems with our support portal provider Desk.com. Existing replies will be handled, queued, and sent when our provider is back up.
Posted Jan 26, 2016 - 08:29 PST
This incident affected: Support & Help Pages.