Emails not sending
Incident Report for SmugMug
Resolved
Emails which were queued to be sent will be resent shortly.
Posted 9 months ago. Jul 25, 2016 - 13:26 PDT
Identified
Site emails have been sent at a very low rate for several hours. We have identified the problem and will have it resolved shortly.
Posted 9 months ago. Jul 25, 2016 - 12:51 PDT
This incident affected: Web.