Statistics delayed
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Sep 01, 2014 - 22:46 PDT
Update
View statistics are continuing to catch up and will be back to normal in about 36 hours.
Posted Sep 01, 2014 - 15:42 PDT
Investigating
Stats are currently behind in processing. We're investigating the underlying cause.
Posted Aug 31, 2014 - 12:37 PDT