Pages loading slowly
Incident Report for SmugMug
Resolved
We've reverted a change that was causing page loading problems on older versions of the Safari browser.
Posted 5 months ago. Dec 08, 2016 - 17:31 PST
Investigating
Pages are loading more slowly than usual. Our engineers are on the case.
Posted 5 months ago. Dec 08, 2016 - 16:29 PST
This incident affected: Web.