Search updates processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 07, 2017 - 22:40 PDT
Investigating
Search updates are processing slowly. This may cause delays in the content of recent photo updates and searches. Our team is investigating this problem.
Posted 2 months ago. Oct 07, 2017 - 19:10 PDT
This incident affected: Search.